Start a new topic

Project doesn't build if we upgrade .NET version to .NET 4.x in Unity

When we upgrade .NET version to .NET 4.x Equivalent in Unity, project doesn't build.

 

ERROR:

 

WARNING: The runtime version supported by this application is unavailable.

Using default runtime: v1.1.4322

The assembly mscorlib.dll was not found or could not be loaded.

It should have been installed in the `C:\Program Files\Unity 2018.2.13f1\Editor\Data\Mono\lib\mono\1.0\mscorlib.dll' directory.



TESTED ON:

Unity 2018.1.0f2 (64-bit)


Hello Harsh. We already answered on a private ticket. I am sorry it still doesn"t work.

I have contacted the technical team to send you a full procedure and workaround. i'll get back to you soon.

Thanks,

Harsh, it seems that this erro is not coming from PIXYZ, but Unity itself. Your Unity installation must be corrupted. The "mono" dll is not coming from PIXYZ Plugin...


You should try to reinstall everything : Unity + PiXYZ Plugin for Unity.

I create empty project, upgrade to .NET 4.x and create a build. It works fine. Then I import PiXYZ and the project stops building. I switch back to .NET 3.5 equivalent and project starts building again.


PS. This thread is about PiXYZ for Unity 2018.1 not any later version.

Login or Signup to post a comment