Start a new topic

Cannot import annotations from while importing .stp files

Hi, I use PIXYZ plugin to import CAD models with 3D annotation data. The annotations are visible in CAD software. But when I try to import the CAD .stp file the annotations and other informations are missing. To be more precise I don’t see text data in the unity scene window. Only model is seen. Is there any way I can see the text data or it cannot be done. Or should I try with other a more suitable cad format. I tried the following formats-.3dxml,.stp,.vrml,.iges,.catpart. But none of them could bring text into scene window. Is there any solution for it.

Hello,


PïXYZ natively reads most 3D annotation types on a wide range of formats. In the PiXYZ PLUGIN for Unity, there is an import setting to enable the import of such data (converted as polylines to fit in Unity's meshes).

This option is named "Import Lines" and is one of the parameters in the Import section of the Import Window.



Let me know if it worked for you.


Regards,

Olivier


Hello,

I tried this option but still it's not importing the annotation. The formats i used are .stp, .3dxml.

The source CAD object is from CATIA. Also we changed the export settings for step in CATIA to Application protocal to 242 and 214. in this format the exported file will have all colour data, PMI data, etc. But i see these are not importing using PiXYZ. Or is there any other way to do it.


In addition, When i import, i see the model tree to be cut short than what it is in CATIA.So my inference is that, I beleive PiXYZ is filtering the data and this is the reason the PMI Data and Annotation colour data are not coming into Unity.


Correct me if am wrong and help me if all these can be done in PiXYZ and how to do it.

If it is not natively doable, can it be done by PiXYZ scripting?

If you are trying to see PMI type annotations, unfortunately those are not yet supported in the PiXYZ PLUGIN for Unity.

As of now, only PiXYZ STUDIO and PiXYZ REVIEW can display PMIs, and there is no way yet to convert PMIs annotation in something that can be viewed in Unity :


Regards,

Olivier

Login or Signup to post a comment